博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
ASA动态NAT转换演示
阅读量:5734 次
发布时间:2019-06-18

本文共 8213 字,大约阅读时间需要 27 分钟。

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

务 实验需求:
1.配置路由器和ASA的接口,实现网络互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT转换表

实验拓扑:

骤 配置思路:
1.配置ASA防火墙对应端口的IP并设置端口名与优先级

  1. 配置R1 RR 各对应端口的IP地址关闭路由关闭,并验证网络是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置远程
    实验步骤:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (远程密码)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名内部)
    security-level 100 (优先级最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(优先级最低)

no shutdown

ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要进行地址转换的网段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定义全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立转换对应关系)
nat (inside,outside) dynamic in-out
q

R1:

enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (关闭路由功能)
ip default-gateway 10.1.1.254(设置网关)
end
ping 10.1.1.254 (验证到网关是否互通)
设置远程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:

enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (验证到网关是否互通)

设置远程

enable
configuration terminal
enable password 123
line vty 0
password 123
end

在R1上远程RR

在RR上远程R1

在ASA输入show xlate 查看NAT转化表

转载于:https://blog.51cto.com/13505118/2056847

你可能感兴趣的文章
「小程序JAVA实战」微信小程序工程结构了解(五)
查看>>
使用列表
查看>>
Edge browser hosts file
查看>>
原生CSS设置网站主题色—CSS变量赋值
查看>>
概率dp - UVA 11021 Tribles
查看>>
webpack 4.0 中 clean-webpack-plugin 的使用
查看>>
数据库神器:Navicat Premium
查看>>
WPF
查看>>
Best website for Photogrammetry
查看>>
中文词频统计
查看>>
POJ 2236 Wireless Network (并查集)
查看>>
python分类
查看>>
linux 中常见的压缩和解压缩的命令
查看>>
GitBlit (1)-- 在linux 安装 GitBlit 并运行
查看>>
Windows与Linux之间的文件自动同步
查看>>
topcoder srm 714 div1
查看>>
20160215
查看>>
mxnet导入图像数据
查看>>
程序是如何执行的(一)a=a+1
查看>>
go : 结构
查看>>